×

diamond

IDEA java:-source 1.5中不支持diamond运算符,请使用-source7或更高版本以启动diamond运算符

woxigouadmin woxigouadmin 发表于2021-03-11 13:21:40 浏览461 评论0

抢沙发发表评论

从github上下载项目下来报错,其本身的环境变量为1.5,可是我本地为1.8,Rebuild的时候编译报错,解决方法

  1. IDEA中File==》Project Setting==》Modules

20191230140544439.png

  1. 选择后点击Apply

  2. File 》 Settings 》 Build, Execution, Deployment》 Compiler》 Java Compiler

20191230140544439.png因为我本地JDK是1.8所以我就填了1.8



版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

本文链接:https://blog.csdn.net/AdminPwd/article/details/103765283